'98 Jeep A/C problem

Moderators: Nacho, Tom Greenleaf, ACProf, acsource

'98 Jeep A/C problem

Postby sampsotr » Tue Jun 28, 2005 8:31 pm

I just desided to fix my A/C on my jeep and I was convinced that it just needed a refill of 134a. I go to pressure check the low end and I think something is wrong. The presure is at 45 psi before i turn on the truck. So I turn it on and the presure falls to zero when the compressor in on and gradually goes back to 45. I talked to a few local shops and they said to add a little to see what it does. Now the pressure is at 52psi and still no cold air.
The clutch cycles about for about 5 seconds and goes off for five seconds then over and over again.
Am I on the right side? I am testing on the valve near the evaporator and not the one on the compresser because the valve won't fit on the compressor.
sampsotr
 
Posts: 2
Joined: Tue Jun 28, 2005 8:20 pm

Postby Guest » Tue Jun 28, 2005 8:45 pm

The 45psi on the low side with the truck off indicates a low charge (unless it was around 40 degrees out) so you have a leak that needs to be found and fixed. Most common leak spot on your Jeep is the evap core if the Grand Cherokee and the shaft seal if the cherokee. The reason it went to zero was the expansion valve closed. You will proably need a new one, especially if you added leak sealer and other junk from a "kit"..Hope this helps..
Feel free to e-mail me if you need flush procedures and vac/charge procedures..
Guest
 

Postby sampsotr » Tue Jun 28, 2005 8:59 pm

It is a regular cherokee. So Can I add the rest of the can. It is that 134a Plus stuff that has the oil in it because I don't know what to do with it. It hasn't worked since I got it (about two years ago) so I just thought it needed refilled. Thanks for the help.
sampsotr
 
Posts: 2
Joined: Tue Jun 28, 2005 8:20 pm

Postby kev2 » Tue Jun 28, 2005 9:57 pm

You are goimg to NEED that high side reading...if the system is restricted as chick suggested it will get dangerous high fast, also $$$$$ faster.....
kev2
 
Posts: 35
Joined: Tue Jun 28, 2005 9:39 pm
Location: Atl. Ga


Return to A/C Questions and Opinions

Who is online

Users browsing this forum: Bing [Bot], The Google [Bot] and 3 guests